Sunday, September 11, 2011

Gedit-latex has been ported to Gedit 3.

So this post is to announce that I just have released gedit-latex 3.1.1. This is the first (unstable) release of Gtk3 port we did of the great plugin by Michael Zeising. You can download it from and please file bugs against GNOME Bugzilla (product:gedit component:latex). We have been using it for quite some time and should be fairly stable. We hope to release Gedit-latex 3.2 along wi th the GNOME 3.2 Release.

Many thanks to Ignacio Casal Quinteiro, John Stowers, Lucas Roesler and Michael Zeising for all their help.



  1. I got this error message in Oneiric Ubuntu with a very simple tex file (\documentclass{article}):

    TypeError: metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases
    ERROR:/build/buildd/pygobject-2.90.3/gi/_gobject/pygobject.c:904:pygobject_new_full: assertion failed: (tp != NULL)
    Aborted (core dumped)

  2. Gonzalo, which versions of gedit, pygobject, gtk and glib do you have? Gedit-latex is targeted to GNOME 3.2. You can also try the gnome-3-0 branch in, which targets GNOME 3.0

    Let me know and feel free to hang out in #gedit at if you need more help.

  3. Gonzaolo, please also submit a bug into gnome's bugzilla so we can track it

  4. This comment has been removed by the author.

  5. I have the Ubuntu Oneiric Ocelot 11.10 Beta-1 defaults:
    gedit 3.1.5,
    python-gobject 2.90.3-1svn1,
    libgtk2.0-0 2.24.6-0ubuntu,
    libglib2.0-0 2.29.90-0ubuntu,
    gnome 3.1.91.

    What do I have to git clone to get the gnome-3-0 version?

    Thanks for all

  6. you do:
    git clone git://
    git checkout gnome-3-0

  7. gonzalo, I just tested against gnome 3.1.91 in fedora 15 and jhbuild and it works Ok

  8. Help! I can't get it to install on my machine. I get the following error:
    "configure: error: Package requirements (
    glib-2.0 >= 2.26.0
    gio-2.0 >= 2.26.0
    gtk+-3.0 >= 3.0.0
    ) were not met:

    No package 'glib-2.0' found
    No package 'gio-2.0' found
    No package 'gtk+-3.0' found"

    How do I install these packages? I assume it's pretty easy, but I just can't find them on synaptic. :-/

    BTW, I'm running Ubuntu oneiric beta and I've just noticed my gedit-latex is still on version 0.2.0. And you say the current version is 3.1.1? What gives? Were versions 1 and 2 just ignored by Canonical?

  9. Ok, Google is my friend. Installing libgtk-dev now and hoping for the best.

  10. Hello
    I got a problem with the installation. It compiles and installs fine but then it does not appear in the plugin list of gedit. Any idea what could be going wrong?

    I tried with gedit-latex 3.1 and 3.3, still the same problem.
    My gedit version is 3.2.0 under ubuntu64 11.10

  11. gedit 3 says that the plugin fails to load. Any idea for a possible solution? I'm running Oneiric with Gedit 3.2.1. Thanks

  12. It works great here. I have two requests, both have to do with optimizing screen use on small screens:

    1. Add an option to hide the LaTeX toolbar.
    2. Add a preview widget. The current solution of using a separate Evince instance works fine, but having it integrated into Gedit allows to go fullscreen and still have the preview in sight.

    Thank you for your work!

  13. This comment has been removed by the author.

  14. Hello,
    I had installed successfully the plugin and it had worked well until that I tried to switch the Latex to Pdf accelerator from Ctrl+Alt+1 to Ctrl+L, gedit close itself when I open a tex file or click on Preferences button within Gedit Latex plugin.

    I also trying to delete the user tools.xml file in ~/home/.config/gedit/latex (a incomplete xml file), now I can open the Gedit Latex Preferences (without changing the accelerator) but when I tried to open the tex files, I got this error:
    TypeError: metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases
    ERROR:/build/buildd/pygobject-3.0.0/gi/_gobject/pygobject.c:929:pygobject_new_full: assertion failed: (tp != NULL)


  15. sudo apt-get install libgtk-3-dev

  16. aaah! I am doing something wrong - everything installed ok - and the plugin is listed - but I cant see the LateX toolbar.. just not there.. newbie driver..

  17. Please, if you have a problem with the plugin, you need to submit a bug into Gnome bugzilla.

  18. Tried installing, finally installed, but gedit is crushing since I enabled the plugin.